Back to overview
Server Lag & Timing Out
Jun 11 at 12:00am GMT-12
Affected services
2b2t - Minecraft
Resolved
Jun 11 at 12:00am GMT-12
2b2t is aware of the current ongoing lag & timing out issues
Affected services
Resolved
Jun 11 at 12:00am GMT-12
2b2t is aware of the current ongoing lag & timing out issues
Affected services